OpticOdds - app.opticodds.com is showing a blank screen. – Incident details
Report an issue
Get updates
Email
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Report an issue
Get updates
Dark mode
Experiencing degraded performance
app.opticodds.com is showing a blank screen.
Resolved
Major outage
Started 6 days ago
Lasted 15 minutes
Affected
Website
Major outage from 1:12 PM to 1:27 PM
App
Major outage from 1:12 PM to 1:27 PM
Updates
Resolved
August 25, 2025 at 1:27 PM
Resolved
August 25, 2025 at 1:27 PM
This incident has been resolved.
Investigating
August 25, 2025 at 1:12 PM
Investigating
August 25, 2025 at 1:12 PM
We are currently investigating this incident.