OpticOdds - Odds are going in and out due to a 3rd party vendor issue. – Incident details

Odds are going in and out due to a 3rd party vendor issue.

Resolved
Partial outage
Started about 16 hours agoLasted 31 minutes

Affected

Website

Partial outage from 12:28 AM to 12:59 AM

App

Partial outage from 12:28 AM to 12:59 AM

API

Partial outage from 12:28 AM to 12:59 AM

Updates
  • Postmortem
    Postmortem

    Problem:

    For the past 3 days, since the start of the NBA Conference finals, around 7:30-8:00 PM EST, there were odds missing or odds not updating at slower frequency. This was not limited to NBA and was affecting all leagues and sports. The endpoints impacted include the /fixtures/odds and our Screen application.

    Analysis:

    We traced the error to a third party vendor issue that was caused by high load due to odds changing and due to an increase in API activity.

    Solution:

    We implemented a couple of solutions on the application level and our cloud vendor also made some adjustments to properly handle the increase in load we were experiencing. We will be monitoring over the next couple of days to verify that these solutions did solve the issue.

  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.